Requirements

The requirements to use All-New MotoSKILL are as follows.  Any machine capable of running the listed browsers below are compatible with our content, unless otherwise noted.

  • Internet Explorer 9+
  • Microsoft Edge
  • Google Chrome
  • Firefox 4+
  • Safari 6+
  • iOS7+
  • Android 2.3+
  • Windows Phone 7

Additionally some plugins and technologies may need to be installed and enabled to see content

  • Javascript is required.  Refer to your internal IT department if it is blocked.
  • Flash may be required for some content
  • Pop-up windows must be allowed for some content.
  • WebGL capability for some content ( Mobile devices and Internet Explorer 8 thru 10 will not work )

If you’re having trouble, we can help!  Contact Us.